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Essa apostila tem como objetivo fornecer as diretrizes para a elaboragdo de um circuito
digital utilizando o diagrama esquematico, na ferramenta Altera Quartus 16.1. Serdao
realizados 0s passos necessarios para a criacdo de um projeto, elaboracdo do
esquematico, simulacdo e programacdo na placa FPGA, sendo realizado também a
exportagao e importagao do projeto no formato qar.

1) Criacao de um projeto no Quartus 16.1

e Abra o Quartus e selecione a opgao File -> New -> New Quartus Prime Project.
e O Project Wizard serd aberto. Siga o procedimento nas telas seguintes:
» Na tela Introduction, pressione Next para seguir a proxima tela.
» Na tela Directory, Name, Top-Level Entity, escolha um diretério e de o
nome esquematico para o projeto. Pressione Next para seguir a proxima
tela.

Directory, Name, Top-Level Entity

What is the working directory for this project?
C:/Users/Alunos/Desktop/projeto E]
What is the name of this project?

esquematico E]

What is the name of the top-level design entity for this project? This name is case sensitive and must exactly match the entity name in the

design file.

esquematico [3

Use Existing Project Settings...

| <eack |[ mea> || rFinsh || cancel |[ rep |

> Na tela Project Type, mantenha a opcdo Empty project e pressione Next
para seguir a préxima tela.
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> Na tela Add Files, existe a possibilidade de adicionar arquivos (vhdl,
formas de onda, esquematicos...) ao seu projeto, porém isso ndo sera
realizado. Pressione Next para seguir a proxima tela.

> Na tela Family, Device & Board Settings, selecione as seguintes opgdes
para escolher a placa DEO-CV:

o Family: Cyclone V

Device: All

Package: Any

Pin Count: 484

Core speed grade: 7

o O O O

Selecione a terceira opcdo da tabela e pressione Next para seguir a
proxima tela.

OBS: A placa selecionada (5CEBA4F23C7) é a placa utilizada no
Laboratério Digital. Outras placas também podem ser escolhidas na
tabela.

> Na tela EDA Tool Settings, é possivel selecionar outras ferramentas para
auxiliar no seu projeto que nao serdo utilizadas aqui. Pressione Next para
seguir a préxima tela.
» Na tela Summary, pressione Finish para finalizar a criacdo do projeto.
e OBS: E possivel apertar o bot3o Finish apds a tela de nomeacdo do projeto. Nesse
caso, sera necessario posteriormente atribuir a placa DEO-CV ao projeto.

2) Descricdo de um sistema digital em VHDL

e Selecione a opgdo File -> New -> Block Diagram/Schematic File abrindo a janela
para a criacdo do esquematico.

(& Blockz bdf B |
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e Afungdo logica que sera implementada é a seguinte:
Y =ABC'+ A'B'C
com a seguinte tabela verdade

A B C Y
0 0 0 0
0 0 1 1
0 1 0 0
0 1 1 0
1 0 0 0
1 0 1 0
1 1 0 1
1 1 1 0

Para isso, serd necessario adicionar portas and de trés entradas, portas or de
duas entradas e portas not no esquematico além de trés pinos de entrada e um
pino de saida.

» Para selecionar a porta and, clique no botdo Symbol Tool e na janela
recém-aberta escreva no campo Name and3. Uma outra alternativa é
seguir o seguinte caminho de diretdrios primitives -> logic -> and3.

» Para selecionar a porta or, clique no botdo Symbol Tool e na janela
recém-aberta escreva no campo Name or2. Uma outra alternativa é
seguir o seguinte caminho de diretdrios primitives -> logic -> or2.

» Para selecionar a porta not, clique no botdo Symbol Tool e na janela
recém-aberta escreva no campo Name not. Uma outra alternativa é
seguir o seguinte caminho de diretérios primitives -> logic -> not.

» Para selecionar os pinos de entrada/saida (input/output), clique no botdo
Pin Tool e selecione a opcdo desejada. Realize um clique duplo sobre o
nome do pino para conseguir altera-lo. Renomeie os pinos de entrada
para A, Be Ce o pino de saida para V.

Vocé devera possuir os seguintes componentes em seu diagrama esquematico:
& Block2 bdf* 8 |

‘EMavACR-O0171 3N \Oo\~"EPsz[d B "olke

e Conecte os componentes conforme a funcdo ldgica descrita acima utilizando o
botdo Orthogonal Node Tool. Em seguida, pressione o botao destacado na figura
para compilar o cédigo. Sera pedido para salvar o arquivo. Ele deve ser nomeado
mesmo nome da entidade descrita (esquematico no caso) que é o mesmo nome
do projeto. Realize a compilacgdo.
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3 Quartus Prime Lite Edition - C/U:

File Edit View Project Assignmen rocessing  Tool indow p Sear
DrEd b2 c Jrsss oblres eadu @
Project Nawgatm{ I\ Hierarchy v]Q@ﬂ x | = Block2 bdt* [x] |

BERa¥ACE-OI1ANNNDOoNNFHLrSLid® [ alieNs

Entity:nstance

#% Cyclone V: SCGXFCTCTF23C8

P esquematico "B

i

e A compilagao sera realizada com sucesso e a seguinte mensagem serd emitida:

> @ Quartus Prime Analysis & Synthesis was successful. 0 errors, 1 warning

3) Simulacdo do sistema digital

e Selecione a opcdo File -> New -> University Program VWF para abrir a janela de
simulagdo com formas de onda.

e Com o click do botdo direito do mouse no canto extremo esquerdo (espaco
branco abaixo de Name), selecione Insert Node or Bus.

O Rle P = e e ¥ P T T R—— o )
File Edit View Simulation Help Search altera.com [~ ]
Me % & A Z ) E B EE T )R 2w 2 [=)8%
Master Time Bar. Ops E B Pointer. 8.6ns Interval: 8.6 ns Start: End:
Value at 0 ps. 80[0 ns 15010 ns 240i0 ns 320;0 ns 400i0 ns ABOiO ns 560i0 ns 640i0 ns 720;0 ns 800i0 ns 83010 ns 960;0 ns
Name
Ops Ops
X Delete Del
Insert Node or Bus.
Grouping 2
Reverse Group or Bus Bit Order
Radix »
B Pproperties

e Aseguinte janela serd aberta, onde a opcdo Node Finder devera ser selecionada.

"
\_ Insert Node or Bus

Name: Use Node Finder to insert ..

Type: [ INPUT A Cancel

Value type: [Q—Level

Node Finder...

4

Radix: [ Binary 24

Bus width: 1
Startindex: 0

Display gray code count as binary count
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e Selecione a opcao List para listar as entradas e saidas da sua entidade como nés.
Em seguida, pressione >> para selecionar todas os nds encontrados. Aperte OK
em seguida.

Filter: | Pins: all 'H OK g ]

Lookin: * V B[ List 1 H Cancel J

Nodes Found: Selected Nodes:

Name Type

Input

Input

= A
»- B Input
» C
X,

ulJ!

Qutput

e Observe que os nés foram incorporados a simulacdo, sendo necessario transmitir
valores aos nds de entrada. Modifique o zoom da janela com botdo Zoom Tool
clicando com o botdo esquerdo do mouse para aumentar o zoom até obter
intervalos de tempo de 10ns (OBS: O botdo direito do mouse diminui o zoom
nesse caso). Com o botdo Selection Tool, arraste o mouse por intervalos de
tempo em cada né com o botdo esquerdo pressionado e altere o valor dele
naquele intervalo, utilizando os botdes Forcing Low e Forcing High. Realize todas
as comblnagoes posswels entre 0s nos de entrada conforme figura abaixo.

(&3 Simulation Waveform Editor - C/Users/Alu =
File Edit View Simulation Help arch altera.com ©

2 VTR NCTE 17 YR e b -
A @) %0 M ZKEHE R EIE 2R 2R 4 EE

Master Time Bar: 0 ps (] [»] pointer: 48.4ns Interval: 48.4ns Start: End:

value at ‘ 0 ps 10.0ns 200ns 30.0ns 40.0ns 50.0ns 60.0ns 70.0ns 80.0ns 90.0 ns 1000 ns 1100 ns 1200 ns

Name
0ps | Ops

BO | |

BO
80 | | ] | | | J |
Bx SRRRRRK

Aperte Ctrl + S para salvar o arquivo de simulacdo ou selecione File -> Save. Salve
0 arquivo com o mesmo nome da entidade (esquematico.vwyf).

< n o »

CEEE

e Antes de realizar a simula¢do, é necessdrio alterar o script utilizado, pois ele
utiliza o nome pré-fornecido pelo Quartus (Waveform.vwf). Selecione
Simulation -> Simulation Settings e realize as modificagdes nos espagos grifados
na figura abaixo, trocando Waveform por esquematico. Pressione Save.
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'@ Simulation Options - - e - ® g‘l

Caution: Improperly modifying these settings can cause the simulation to fail

HDL Language: () Verilog @ VHDL (The language used for the testbench and netlist)

Functional Simulation Settings | Timing Simulation Settings

Testbench Generation Command (Functional Simulation):

sjeto/Waveform.vwf* --testbench_file="C:/Users/Alunos/Desktop/projeto/simulation/qsim/Waveform.vwf.vht"

Netlist Generation Command (Functional Simulation):

quartus_eda --write_settings_files=off --simulation --functional=on --flatten_buses=off --tool=modelsim_oer
ModelSim Script (Functional Simulation):

onerror {exit -code 1}
vlib work
vcom -work work sistema_digital.vho
vcom -work work Waveform.vwf.vht
vsim -novopt -c -t 1ps -L cyclonev -L altera -L altera_mf -L 220model -L sgate -L altera_lnsim work.contador_¢
ved file -direction sistema_digital. msim.ved
ved add -internal contador_4bits_vhd_vec_tst/*
ved add -internal contador_4bits_vhd_vec_tst/i1/*
proc simTimestamp { {

echo “Simulation time: $::now ps*

if { [string equal running [runStatus]] }{

after 2500 simTimestamp

}
}
after 2500 simTimestamp
run -all
quit -f

[ Save J[ Cancel ]

e Selecione o botdo Run Functional Simulation para rodar a simulacao.

b Simulation Waveform =1
File Edit View Simulation Help Search altera.com @
@ oo M 20 E B OEE 2 )E [k 2 EER
Master Time Bar. Ops E B Pointer: 48.4ns Interval: 48.4ns Start: End:
Value at 0 ps 10.(') ns 20.9 ns 30.9 ns 409 ns 50,9 ns 609 ns 70.9 ns 509 ns 909 ns 100i0 ns 'HOiO ns 120i0 ns
Name
Ops Ops
B A B8O | |
- B BO
B 80 | | | | | | [ |
% v Bx SRRRERRK

A simulacdo deverd ocorrer corretamente. Observe os resultados e verifique que
o resultado obtido condiz com o valor da tabela verdade fornecida acima.
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File Edit View Simulation

e | % & 4 2 )€ E B HEE 2 )E = xd 2 [F)5
Master Time Bar: Ops [z] E] Pointer: 34.89 ns Interval: 34.89 ns | Start: | End:
0 ps 10.(I7 ns 20.9 ns 30.(‘) ns 40.‘0 ns 50.9 ns 60(‘) ns 70.9 ns 809 ns 909 ns 1ooio ns 1 10i0 ns 1 2010 ns i
R Value at ops
ops

- A BO I |
5 B B0 S S T I (S R R
B e e | | ] | | | | |
> Y BO

OBS: Caso o script ndo seja alterado, o seguinte erro serd obtido durante a

simulagao:

" : : .
(3 Simulation Flow Progress M
i Error J
e S S s =

Info: agreement for further details.

Info: Processing started: Mon Feb 06 14:32:08 2017
Info: Command: quartus_eda --gen_testbench --tool=modelsim_oem --format=vhdl --
write_settings_files=off sistema_digital -c sistemna_digital --
vector_source=C:/Users/Alunos/Desktop/projeto/Waveform.vwf --
testbench_file=C:/Users/Alunos/Desktop/projeto/simulation/gsim/Waveform.vwf.vht
Warning (18236): Number of processors has not been specified which may cause overloading on shared
machines. Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate value
for best performance.
Error (199014): Vector source file C:/Users/Alunos/Desktop/projeto/Waveform.vwf specified with --
testbench_vector_input_file option does not exist
Error: Quartus Prime EDA Netlist Writer was unsuccessful. 1 error, 1 warning

Error: Peak virtual memory: 566 megabytes

Error: Processing ended: Mon Feb 06 14:22:09 2017

Error: Elapsed time: 00:00:01

Error: Total CPU time (on all processors): 00:00:01

m

Error.

1

e OBS: Caso vocé sempre utilize o nome sugerido pelo Quartus ao salvar o arquivo
da simulacdo pela primeira vez, ndo sera necessario alterar o script da simulagdo.

4) Salvando o projeto realizado no Quartus.

e O formato para exportacao de um projeto no Quartus é o qar, e é equivalente a
um zip feito especificamente para esse propdsito. Para gera-lo selecione a opgao
Project -> Arquive Project, abrindo a seguinte janela.

Archive file name: esquematico

[™] Archive all revisions

o (e (R
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Mude o nome do arquivo e/ou o diretério de destino caso desejado e selecione
Archive para geral o gar. A seguinte janela aparecerd. Caso o diretério nao tenha
sido alterado, o arquivo deve-se encontrar no mesmo diretdério onde estd o

projeto.

rG Quartus Prime u

Project successfully archived.

5) Abrindo um gar no Quartus

Abra o Quartus e selecione a op¢ao File -> Open. Encontre o diretério onde o
arquivo qar esta localizado e coloque no canto inferior direito a op¢do de arquivo
Quartus Prime Archive Files para visualiza-lo. Selecione o arquivo e aperte Abrir,

gerando a seguinte janela.
'3 Restore Archived Project

Archive name:

C:\Users\Alunos\Desktop\projeto\esquematico.qar

]
Destination folder:
™

C:/Users/Alunos/Desktop/projeto/esquematico_restored

"] Overwrite any existing files in the destination folder

| ok || cancel || mep |

Aperte OK para abrir o gar. Apds o término do processo, observe que no
Project Navigator, localizado no canto esquerdo é possivel selecionar a op¢do
Files para visualizar todos os arquivos contidos no projeto.

O Quartus Prime e Edioon - CTUSB R u/Oeie:

File Edit View Project Assignments Process

OfF | - TR C |sistema_digital

Project Navigator | 4\ Hierarchy Q@& x
#% Hierarchy

E Files

&% Cyclone V: 5¢ il Design Units

® contador | ¥ IP Components
[l1 Revisions
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e Para realizar uma simulacdo de um arquivo contido no gar, é necessario realizar
algumas modificagdes no script, alterando o diretdrio utilizado por ele. Esse
problema ocorre, pois, o gar salva no script da simulagdo o diretdrio original
onde foi criado o projeto, antes de ser gerado. Abra o arquivo da simulagao,
selecione Simulation -> Simulation Settings e realize as modificagbes nos
espacos grifados na figura abaixo, trocando o caminho do diretério original pelo
caminho do seu diretdrio. Pressione Save e simule o arquivo.

Caution: Improperly modifying these settings can cause the simulation to fail

HDL Language: C) Verilog ©) VHDL (The language used for the testbench and netlist)

Functional Simulation Settings | Timing Simulation Settings ‘

Testbench Generation Command (Functional Simulation):

*C:/Users/Alunos/Desktop/projeto/esquematico.vwf” --testbench_file="C:/Users/Alunos/Desktop/projeto/sim

Netlist Generation Command (Functional Simulation):

verilog --output_directory="C:/Users/Alunos/Desktop/projeto/simulation/gsim/" esquematico -c esquematico

ModelSim Script (Functional Simulation):

onerror {exit -code 1}
vlib work
vlog -work work esquematico.vo
vlog -work work esquematico.vwf.vt
vsim -novopt -c -t 1ps -L cyclonev_ver -L altera_ver -L altera_mf_ver -L 220model_ver -L sgate_ver -L altera_In
vcd file -direction esquematico.msim.vcd
ved add -internal esquematico_vlg_vec_tst/*
ved add -internal esquematico_vlg_vec_tst/i1/*
proc simTimestamp { {

echo "Simulation time: $::now ps*”

if { [string equal running [runStatus]] } {

after 2500 simTimestamp

}
}
after 2500 simTimestamp
run -all
quit -f

Restore Defaults [ Save J[ Cancel

6) Programando o projeto na placa FPGA DEO-CV

e Para programar o projeto na placa DEO, caso a designacdo do device ndo tenha
sido realizada na criagdo do projeto é necessdrio primeiro selecionar o
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dispositivo. E possivel também alterar o device ja designado. Selecione a opgdo
Assigments -> Device. Escolha as seguintes opcdes:
o Family: Cyclone V
Device: All
Package: Any
Pin Count: 484
Core speed grade: 7

O O O O

Selecione a terceira opc¢do da tabela e pressione OK.

@ Device

Device Board

Select the family and device you want to target for compilation.

You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Device family Show in 'Available devices' list

Family: [Cyclonev (E/GX/GT/SX/SE/ST) '] Package: [Any

Device: [All '] Pin count: [484

Core speed grade: [7

Target device

Auto device selected by the Fitter Name/fitter:

@ Specific device selected in 'Available devices' list Show advanced devices

ther: n/a i 5 A
Other: 'n/a Device and Pin Options...

Available devices:

Name Core Voltage GXB Channel PMA GXB Channel PCS |:|
S5CEBA2F23C7 1.1V =7

S5CEBA2U18C7

SCEBA4F23C7

SCEBA4U19C7

<

Migration Devices...| 0 migration devices selected

[W Buy Software] [ OK

e Em seguida escolha a pinagem da placa. Para isso selecione a opgdao Assigments
-> Pin Planner. A seguinte janela sera aberta onde os nds referentes ao
esquematico estarao localizados em uma tabela no canto inferior.

OBS: Caso o canto inferior esteja vazio, compile o projeto conforme segao 2.
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[ pin Planner - C/Users/Aluncs/

File Edit View Processing Tools Window Help Search altera.com (]
Report @e x Pin Legend @& x
= W; T Top View - Wire Bond ¢ - =
) Reronrerevatte Symbol Pin Type s
Q Cyclone V - 5CGXFC7C7F23C8 O userijo
¥ — [ ) User assigned ..
X B i e e et o ® g
TNWENOOADOORVEOOD ©&© OOV~ ®  unbondedpad
IS e VV X XD @@AV@@@@ CORRAOG ®  reservedpin
C‘E]E @A@ @@V@@@@A < ®  Dev.oe
[:‘g o W @@ A\ /\@v@ @©|o ® DIFF_n =
o £ @ ©©V© VA DO « ) DIFF_p
= ) n QOOO ©lo} ©£\E> g [n DIFF—n output
P Je JOOUARROOVEOE - LR
2 " @@D@ DOLIAGALGV] A
= ; ©OONOAOAYADOBYOE): 9 o
2 © OVO© QOADE @)« & pos
§ OGSO OURSRT: . |©
Groups | Report M (U] [ LH i [T Kin L
£ — " \V/o]ii @A@ QY » % o
o [Tk . QOOVADNAONAG@DOAAG) - < -
5o 4 I~ Early Pin Planning R _@&@ @O\ EOOE @MA%@ w [ 5 GX_X*n
@ B Early Pin Planning T QOQOADRORVOROOVE| " e exxe
= P Run1/O Assignment Analysi| u D@v@@@@&@@@ @OEQO)|v O Other PLL
B Export Pin Assignments... ) Y XA©©>< i ounu @@@@V ¥ © MSELO
B Pin Finder... by O QAR @ w @ MSEL1
4 I Highlight Pins . % ©D%AA©©©© oo & =
sl ©OOOYODOOAODOOAG-
&8 yosanis @DE) QVOOORVOAQOV/DEO®E)|=
VREF Groups 12 3 4 5 6 7 58 5101121 1151617181 020 2 CONEZDONE
B B == DCLK
~ [] Edit !men[pins:au -
@ Node Name Direction Location 1/O Bank VREF Group Fitter Location 1/O Standard Reserved Current Strength Slew Rate Differential Pair =r Analog Sett
» A Input PIN_US. 2.5V (default) 12mA (default)
» B Input PIN_T7 2.5V (default) 12maA (default)
B C Input PIN_V6 25V (default) 12mA (default)
Y Output PIN_T8 2.5V (default) 12mA (default) 1 (default)

<<new node>>

e Na coluna Location da tabela, selecione a pinagem correta da placa DEO (chaves,
botdes, leds...) correspondente para cada nd do sistema. Para isso, utilize o
arquivo contendo as informacdes da pinagem da placa localizado no site da
disciplina. Em seguida, compile novamente o projeto para salvar as mudangas
feitas na pinagem.

e Pressione o botdo Programmer para abrir uma nova janela. Em seguida,
verifique se a opcdo Hardware Setup esta em USB-Blaster. Em caso contrario,
verifique se a placa estd ligada e conectada ao computador e clique no botao
Hardware Setup para adiciona-la. Selecione Add Files, va para o diretério
output_files e selecione o arquivo esquematico.sof.

Ci Quartus Prime Lite Edition - C:/L

T R

OrEH

esquematico

S ESL D KO Q&R S

Project Navigator{ A Hierarchy

}Q@sx | &

Entitylnstance
4N Cyclone V: SCGXFCTCTF23C8

E3 esquematico 8
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BRa¥AcR-O11AN\N\NO0

o]

esquematico.bdf

~EERAzed

=] hi"C

co- Chaintcd]

S =)

D -C:

& Hardware Setup...| USB-Blaster [USB-1]

[7] Enable real-time ISP to allow background programming when available

Search altera.com o

P start
b Stop
3 Delete
% Change File
& save File
i up

% pown

File Device Checksum Usercode

Program/  Verify  Blank-
Configure

Examine
Check

PCS-EPUSP
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e Pressione Start para transmitir o projeto para a placa FPGA.

Search altera.com

File Edit View Processing Tools Window Help

Hardware Setup...| USB-Blaster [USB-1] Mode: |JTAG

Enable real-time ISP to allow background programming when available

»h ot File Device Checksum Usercode Program/  Verify  Blank- Examine

— Configure Check
{ wl Stop ‘

output_files/esquemati.. SCGXFC7C7F23  OOEC3133  OOEC3133 = O

’: x Delete I\

LW Change File.“,\

[ mSave File |

L thue |

{ 1% Down

ECONCCICICRR
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