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Essa apostila tem como objetivo fornecer as diretrizes para a elaboragdo de um
circuito digital em VHDL, na ferramenta Altera Quartus 16.1. Serdo realizados os
passos necessarios para a criacdo de um projeto, escrita e compilacdo do codigo em
VHDL, simulacdo do cédigo e programacao na placa FPGA, sendo realizadas também a
criagdo e a restauragdo do projeto no formato qar.

1) Criacao de um projeto no Quartus 16.1

e Abra o Quartus e selecione a opgao File -> New -> New Quartus Prime Project.
e O Project Wizard sera aberto. Siga o procedimento nas telas seguintes:
» Na tela Introduction, pressione Next para seguir a proxima tela.
» Na tela Directory, Name, Top-Level Entity, escolha um diretério e de o
nome contador_4bits para o projeto. Pressione Next para seguir a
proxima tela.

e . , = T— X
h New Prqectw fizard . . . . " - " |
Directory, Name, Top-Level Entity
What is the working directory for this project?
C:/Users/Alunos/Desktop/projeto Q

What is the name of this project?

contador_4bits Q

What is the name of the top-level design entity for this project? This name is case sensitive and must exactly match the entity name in the

design file.
contador_4bits Q

Use Existing Project Settings...

i ) (e (e

> Na tela Project Type, mantenha a opgdo Empty project selecionada e
pressione Next para seguir a proxima tela.
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> Na tela Add Files, existe a possibilidade de adicionar arquivos (vhdl,
formas de onda, esquematicos...) ao seu projeto, porém isso ndo serd
realizado. Pressione Next para seguir a préxima tela.

> Na tela Family, Device & Board Settings, selecione as seguintes opgdes
para escolher a placa DEO-CV:

o Family: Cyclone V

Device: All

Package: Any

Pin Count: 484

Core speed grade: 7

o O O O

Selecione a terceira opcdo da tabela e pressione Next para seguir a
proxima tela.

OBS: A placa selecionada (5CEBA4F23C7) é a placa utilizada no
Laboratério Digital. Outras placas também podem ser escolhidas na
tabela.

> Na tela EDA Tool Settings, é possivel selecionar outras ferramentas para
auxiliar no seu projeto que nao serao utilizadas aqui. Pressione Next
para seguir a proxima tela.
» Na tela Summary, pressione Finish para finalizar a criacdo do projeto.
e OBS: E possivel apertar o botdo Finish apés a tela de nomeacdo do projeto.
Nesse caso, sera necessario posteriormente atribuir a placa DEO-CV ao projeto.

2) Descricdao de um sistema digital em VHDL

e Selecione a opc¢ao File -> New -> VHDL file abrindo a janela para a edi¢dao do
codigo em VHDL.

e Edite ou copie o cddigo escrito na figura abaixo que descreve o comportamento
simplificado de um contador de 4 bits. Em seguida, pressione o botdo
destacado na figura para compilar o cddigo. Sera pedido para salvar o arquivo.
Ele deve ser nomeado com o mesmo nome da entidade descrita
(contador_4bits no caso) que é o mesmo nome do projeto. Realize a
compilagao.
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& Quartus P

File Edit View Project Assignments Processing Tools Window Help

Or=d 0| D C | [contadosaits Jresse oplrko @AaVE @

Project Navigator | 4 Hierarchy v|a@e x ' ¢ Vhdl1.vhd* 2 ‘7
= = == s =
Entity:Instance @ &8 4 EE AN ‘b @ - @ ——
< 3 -— VHDL de um contador de 4 bits
4% Cyclone V: 5SCGXFC7C7F23C8 2
= 3 library ieee;
® contador_sbits & 4 use ieee.std logic_1164.all;
5 use ieee.std_logic_arith.all;
6
7 Bentity contador_4bits is
8 = port(clock : in std_logic;
9 clear : in std_logic;
10 load : in std_logic;
11 Q : out std_logic_vector (3 downto 0)
12 DN
13 end contador_4bits;
14

15 BHarchitecture exemplo of contador_4bits is
16 Lsigna'l IQ: unsigned (3 downto 0);

17

18 [Ebegin

19 @ grocess (clock, clear, load, 1Q)
20 egin

2

22 = if clock’'event and clock = "1"' then
23 [B if clear = '1" then

24 F IQ <= (others => "07");

25 [ elsif load = "1" then

26 IQ <= IQ + 1;

27 end if;

28 end if;

29

30 Q <= std_logic_vector (IQ);

31 end process;

32 end exemplo;

e A compilacdo sera realizada com sucesso e a seguinte mensagem sera emitida:

o i Quartus Prime Analysis & Synthesis was successful. 0 errors, 1 warning

3) Simulacdo do sistema digital

e Selecione a opc¢do File -> New -> University Program VWF para abrir a janela
de simulagdo com formas de onda.
e Com o click do botdo direito do mouse no canto extremo esquerdo (espaco

branco abaixo de Name), selecione Insert Node or Bus.
5 Siuttion Worcom i G oo g e el W o Re _ AET

File Edit View Simulation Help Search altera.com [~ ]
e %o 4 2 ) HE B EE 2 )E 2 8 2 B
Master Time Bar. Ops E Pointer. 8.6ns Interval: 8.6ns Start: End:
Value at 0 ps. 809 ns 16010 ns 240i0 ns 320i0 ns 400i0 ns 4BOIO ns SSOIO ns 540i0 ns 720]0 ns 800i0 ns 830.‘0 ns 960;0 ns
Name
Ops Ops
X Delete Del
Insert Node or Bus.
Grouping 2

Reverse Group or Bus Bit Order

Radix »

B Pproperties

e A seguinte janela serda aberta, onde a op¢do Node Finder deverd ser
selecionada.

Laboratério Digital PCS-EPUSP



"
\_# Insert Node or Bus

Name: Use Node Finder to insert ..
vee (oo o) (o]

Value type: [Q-Level 'J

Radix: [Binary ']
Bus width: 1
Startindex: 0

Display gray code count as binary count

<

e Selecione a opcdo List para listar as entradas e saidas da sua entidade como
nds. Em seguida, pressione >> para selecionar todas os nds encontrados.
Aperte OK em seguida.

L A
3 Node Finder "
Named: * Filter: {Pins: all '] [ oK3 ]
Lookin: * U {1 List ] { Cancel ]

Nodes Found: Selected Nodes:
Name Type Name Type
B clear input - clear input
@ clock Input B 1" clock Input
»- load Input o | @ load Input
Q‘R Q Output Group %‘ Q Output Group
< |
= Q[0] Output @ Q[0] Output
> o[1] Output ® 0[1] Output
> Q2] Output ‘> 0[2] Output
® Q3] Output ® a3 Output
[

e Observe que os nds foram incorporados a simulacdo, sendo necessdrio
transmitir valores aos nds de entrada. Para o clock, clique nele e selecione o
botdo Overwrite Clock. Em seguida escolha um periodo adequado para
visualizar as mudangas no contador. Sera utilizado aqui um periodo de 10ns.
OBS: Vocé pode utilizar o botdo de zoom para aumentar ou diminuir o zoom
das formas de onda com o botao esquerdo ou o direito respectivamente.
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. e
istema_digital - sistema_digital - [Waveform.vwi]*

(&8 simulation Waveform Editor - Cy

O MoZ XD XE B X 2 Al - - 8%
QK0 A EEE B OCPEPE R oT ek

Master Time Bar: Ops E] Pointer. 52.58 ns Interval: 52.58 ns Start: Ops End: 1.0us

value at 0 ps 80.0ns \160i0 ns 240,0ns 3200 ns 4000 ns 480,0 ns 560,0 ns 640,0ns 7200ns 800,0 ns 880,0ns 9600 ns
Name -

Ops ops \
cdear  BO

i
-»
- clock BO \
®  load B0 \
N
& v a BXXXX \\ XXXX
& Clock =)

Base waveform on time period

e [o0 .

Duty cycle (%): 50

e Clique no nd clear e deixe em ativo baixo com o botdo Forcing Low em seguida
cligue no nd load e deixe em ativo alto com o botdo Forcing High. Aperte Ctrl +
S para salvar o arquivo de simulagdo ou selecione File -> Save. Salve o arquivo
com o mesmo nome da entidade (contador_4bits.vwf).

e Antes de realizar a simulacdo, é necessario alterar o script utilizado, pois ele
utiliza o nome pré-fornecido pelo Quartus (Waveform.vwf). Selecione
Simulation -> Simulation Settings e realize as modificacbes nos espacos
grifados na figura abaixo, trocando Waveform por contador_4bits. Pressione

Save.

- ' ~
\_# Simulation Options - - - - - — - @
Caution: Improperly modifying these settings can cause the simulation to fail

HDL Language: () Verilog @ WVHDL (The language used for the testbench and netlist)

Functional Simulation Settings Timing Simulation Settings

Testbench Generation Command (Functional Simulation):

sjeto/Waveform vwf" --testbench_file="C:/Users/Alunos/Desktop/projeto/simulation/gsim/Waveform. vwf.vht"
Netlist Generation Command (Functional Simulation):

quartus_eda --write_settings_files=off --simulation --functional=on --flatten_buses=off --tool=modelsim_oen
ModelSim Script (Functional Simulation):

onerror {exit -code 1}
vlib work
vcom -work work sistema_digital.vho
vcom -work work Waveform.vwf.vht
vsim -novopt -c -t 1ps -L cyclonev -L altera -L altera_mf -L 220model -L sgate -L altera_Ilnsim work.contador_<
vcd file -direction sistema_digital. msim.vcd
vcd add -internal contador_4bits_vhd_vec_tst/*
vcd add -internal contador_4bits_vhd_vec_tst/i1/*
proc simTimestamp { {

echo “Simulation time: $::now ps”

if { [string equal running [runStatus]] } {

after 2500 simTimestamp

}
}
after 2500 simTimestamp
run -all
quit -f

[ Save ] l Cancel
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e Selecione o botao Run Functional Simulation para rodar a simulagao.

B Simolation Waveform Editor - C/3ers/Alurca/Deskion projeto/eiete dhtal - stemma il IWaverommvw]” b i N i o
File Edit View Simulation Help Search altera.com ‘

e X% & M Z O E B E

Master Time Bar: 0 ps

e & [Ek =~ @5

(] [+] pointer: 69.31ns Interval: 69.31ns Start: Ops End: Ops

Valueat
Name
ops

‘3_ clear BO

B cock BO

» load B1

® ra B XXXX
[ ]

0 ps 100ns 200ns 30.0ns 400ns 50.0 ns 60.0ns 700ns 80.0ns 90.0ns 100,0ns 110.0ns 1200 ns

ops

I e [ S o e SN o O D N o T D T SO N S

A simulagdo devera ocorrer corretamente. Observe os valores e verifique que o

resultado obtido condiz com o esperado. O contador é incrementado a cada
borda de subida do clock, apds atingir o valor 1111 ele é zerado e reinicia a
contagem.

(G Simulation Waveform Editor - /U

k@) X & L EEHERER

projeto/sistemadigital - sistema_digital - [sistema_digital20170206143308.5im.vwf (Readu AR

G (=8

Master Time Bar: 0 ps 3358 ns Interval: 33.58 ns Start End:

valeat ||oPs 100ns 200ns 300ns 400ns 500ns 600ns 700ns 800ns 900ns 1000 ns 1100ns 1200ns

Name

ops Ops
» clear BO
B cock  BO NN [ IS ) O S e S ) Uy IS S [y S
» load B1
® va B 0000 0000} 0001 X__ 0010 X 0011 X _ o010 X 0101 X _ om0 X o011 X 1000 X 1001 1010 X 1011 X_ 1100

OBS: Caso o script ndo seja alterado, o seguinte erro serd obtido durante a
simulacdo:

p
s Simulation Flow Progress @
)

Error i

Error.

Y [ e

Info: agreement for further details.

Info: Processing started: Mon Feb 06 14:32:08 2017
Info: Command: quartus_eda --gen_testbench --tool=modelsim_oem --format=vhdl --
write_settings_files=off sistema_digital -c sistema_digital --
vector_source=C:/Users/Alunos/Desktop/projeto/Waveform.vwf --
testbench_file=C:/Users/Alunos/Desktop/projeto/simulation/gsim/Waveform.vwf.vht
Warning (18236): Number of processors has not been specified which may cause overloading on shared
machines. Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate value
for best performance.
Error (199014): Vector source file C:/Users/Alunos/Desktop/projeto/Waveform.vwf specified with --
testbench_vector_input_file option does not exist
Error: Quartus Prime EDA Netlist Writer was unsuccessful. 1 error, 1 warning

Error: Peak virtual memory: 566 megabytes

Error: Processing ended: Mon Feb 06 14:22:09 2017

Error: Elapsed time: 00:00:01

Error: Total CPU time (on all processors): 00:00:01

m

4
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e OBS: Caso vocé sempre utilize o nome sugerido pelo Quartus ao salvar o
arquivo da simulagdo pela primeira vez, ndo sera necessario alterar o script da

simulagao.
4) Salvando o projeto realizado no Quartus.

e O formato para exportacao de um projeto no Quartus é o qar, e é equivalente a
um zip feito especificamente para esse propdsito. Para gera-lo, selecione a
opc¢ao Project -> Arquive Project, abrindo a seguinte janela.

. .
(U@ Archive Project &J

Archive file name: contador_4bits E]

[™] Archive all revisions

[ Archive ][ Cancel ][ Help ]

.

e Mude o nome do arquivo e/ou o diretério de destino caso desejado e selecione
Archive para gerar o gar. A seguinte janela aparecera. Caso o diretério ndo
tenha sido alterado, o arquivo deve-se encontrar no mesmo diretdrio onde estd

0 projeto.

e S
U Quartus Prime @

Project successfully archived.

—

5) Abrindo um gar no Quartus

e Abra o Quartus e selecione a opc¢ao File -> Open. Encontre o diretério onde o
arquivo gar estd localizado e coloque no canto inferior direito a opc¢do de
arquivo Quartus Prime Archive Files para visualiza-lo. Selecione o arquivo e
aperte Abrir, gerando a seguinte janela.
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-
(@ Restore Archived Project

Archive name:
C:\Users\Alunos\Desktop\projeto\contador_4bits.qar E]
Destination folder:

C:/Users/Alunos/Desktop/projeto/contador_4bits_restored

(| Overwrite any existing files in the destination folder

| ok || cancel |[ nmep |

M ~

e Aperte OK para abrir o gar. Apds o término do processo, observe que no
Project Navigator, localizado no canto esquerdo é possivel selecionar a op¢ao
Files para visualizar todos os arquivos contidos no projeto.

UQuartus Prime Lite Edition - CJD!IAIunoleesm
File Edit View Project Assignments Process

O D2 ]sistema_digital

Project Navigator | 4\ Hierarchy. va@e x

4% Hierarchy

E Files

4% Cyclone V: 50 g% pesign Units
® contador | ¥ IP Components
I]-I Revisions

e Para realizar uma simula¢do de um arquivo contido no qar, é necessario realizar
algumas modificacdes no script, alterando o diretério utilizado por ele. Esse
problema ocorre, pois, o qar salva no script da simulacdo o diretdrio original
onde foi criado o projeto, antes de ser gerado. Abra o arquivo da simulagao,
selecione Simulation -> Simulation Settings e realize as modificagdes nos
espacos grifados na figura abaixo, trocando o caminho do diretdrio original
pelo caminho do seu diretério. Pressione Save e simule o arquivo.
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- — — - — — — S
(& Simulation Options E

Caution: Improperly modifying these settings can cause the simulation to fail

HDL Language: () Verilog @ VHDL (The language used for the testbench and netlist)

Functional Simulation Settings | Timing Simulation Settings

Testbench Generation Command (Functional Simulation):

»s‘Des ktog‘groieto‘contador 4bits.vwf" --testbench_file="C:/Users/Alunos/Desktop/projeto/simulation/gsim/

Netlist Generation Command (Functional Simulation):

dl --output_directory="C:/Users/Alunos/Desktop/projeto/simulation/gsim/" sistema_digital -c sistema_digital

ModelSim Script (Functional Simulation):

onerror {exit -code 1}
vlib work
vcom -work work sistema_digital.vho
vcom -work work contador_4bits.vwf.vht
vsim -novopt -c -t 1ps -L cyclonev -L altera -L altera_mf -L 220model -L sgate -L altera_lnsim work.contador_¢
ved file -direction sistema_digital msim.vcd
ved add -internal contador_4bits_vhd_vec_tst/*
vecd add -internal contador_4bits_vhd_vec_tst/i1/*
proc simTimestamp {} {

echo "Simulation time: $::now ps*

if { [string equal running [runStatus]] } {

after 2500 simTimestamp

}
}
after 2500 simTimestamp
run -all
quit -f

e e
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6) Programando o projeto na placa

FPGA DEO-CV

e Para programar o projeto na placa DEO, caso a designagao do device nao tenha
sido realizada durante sua criacdo, € necessario primeiro selecionar o
dispositivo. E possivel também alterar o device ja designado. Selecione a op¢do
Assigments -> Device. Escolha as seguintes opcdes:

o Family: Cyclone V
Device: All

Package: Any

Pin Count: 484
Core speed grade: 7

o O O O

Selecione a terceira opc¢ao da tabela e pressione OK.

_@ Device

Device Board

Select the family and device you want to target for compilation.

You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Device family

Show in 'Available devices' list

Auto device selected by the Fitter

@ Specific device selected in 'Available devices’ list

Family: [CycloneV(E/GX/GT/SX/SE/ST) '] Package: [Any ']
Device: [All '] Pin count: [484 '}
Target device Core speed grade: [7 ']

Name filter:

[¥] show advanced devices

ther: n/a

. Device and Pin Options...
Available devices:

Name Core Voltage ALMs Total 1/0s GPIOs GXB Channel PMA GXB Channel PCS l:,l
S5CEBA2F23C7 1.1V 9430 224 224 0 0 =
5CEBA2U19CT7 1.1V 9430 224 224 0 0
SCEBA4F23C7 1.1V 18480 224 224 0 0 I
SCEBA4U19C7 1.1V 18480 224 224 0 0
-4_‘__. e T ———T—— = .]- i . = »

Migration Devices...| 0 migration devices selected

[# Buysoftware] | ok || cancel || hep |

e Em seguida escolha a pinagem da placa. Para isso selecione a opgao

Assigments -> Pin Planner. A
referentes ao contador de 4 bits
inferior.

seguinte janela sera aberta onde os nés
estardo localizados em uma tabela no canto

OBS: Caso o canto inferior esteja vazio, compile o projeto conforme segao 2.
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[ pin Planner - Ci/Users/Aluncs

File Edit View Processing Tools Window Help Searc (]
Groups m@me x Pin Legend @a x
= . i g
3 Top View - Wire Bond =
® Named: * - Symbol Pin Type 2
Q Node Name Direction Cyclone V - 5CGXFC7C7F23C8 O userijo
> 3 Q[3.0] Output Group o User assigned|..
A o, | =
Tf|—newsroue>> @123 iscTssmnuBus e BERR AR @  rierassigned..
9} [0)XOIOIOI DAVLOI0] DIOY:XOIOI DIOAVAO) @ unbondedpad
° DVOOORAD@E - @  Resenvedpin
= < =& OACR/AOOVE < € DEV_OE
o OOAAND/N\OVE@E)» OFF _n =
=f e [ @@@X&@D@@ B ) DIFF_p
@l — OOVYOOOAD - [ ——"
..: == AGOOOVODO) ¢ nouipu
5 ul OITIAOA @-@v " o) DIFF_p output
- BE NAOORBVEOE) ORI
# VAV QOLADR O « s oos
| R 3 LEE NOPOAVO, $  Dpose
[3) croups | Report VAV QAR @O [z T e B
B, i N% ADOOV] » 0 ax
o - ONOOD O ’ o axe
= 4 I Early Pin Planning = = ] @O0, OO ® ==z [ exxn
o LMD =
- W ey Pin Planning... T W @v@@@@ Q" 2] X _X*p
h P Run IIOAsslgnmen(Analysli: Y ‘%% A'@ @@gg% y L) OtherPLL
y " | v INii v y
.: :xpdon Pin Assignments... MEE OAD O ® :Z::)
- in Finder... VWD@ XAAODOAADGOBOVOORD) v O
4 B Highlight Pins e NOOOOVOREOAGROOAG) < MSEE
5 /o anks S EKSODBOVOOODYOACOVD OE) MSEL3
BB VREF Groups 12 34 56 7 &8 9 1011 1213 151617 819 2 A 2 5 CONF_DONE
oy = ‘ . e [ = @ DCLK il
[ % | Named: * ~ [] edit ‘F»ker.[Pms: all -
)
Node Name Direction Location 1/0 Bank VREF Group Fitter Location 1/O Standard Reserved Current Strength Slew Rate Differential Pair =r Analog Sett
@
- clear Input PIN_N20 2.5V (default) 12mA (default)
- clock Input PIN_M16 2.5V (default) 12mA (default)
B load Input PIN_M22 2.5V (defaul) 12mA (default)
% a3 Output PIN_L22 2.5V (defaul) 12mA (default) 1 (default)
% 0[2] Output PIN_M18 2.5V (default) 12mA (default) 1 (default)
S l1] Output PIN_N19 2.5V (default) 12mA (default) 1 (default)
% afo) Output PIN_L18 2.5V (defauly) 12mA (default) 1 (default)
<<new node>>

e Na coluna Location da tabela, selecione uma pinagem adequada da placa DEO
(chaves, botdes, leds...) correspondente para cada né do sistema. Para isso,
utilize o arquivo contendo as informagdes da pinagem da placa localizado no
site da disciplina. Em seguida, compile novamente o projeto para salvar as
mudancas feitas na pinagem.

e Pressione o botdo Programmer para abrir uma nova janela. Em seguida,
verifique se a op¢do Hardware Setup esta em USB-Blaster. Em caso contrario,
verifique se a placa esta ligada e conectada ao computador e clique no botado
Hardware Setup para adiciona-la. Selecione Add Files, va para o diretdrio
output_files e selecione o arquivo contador_4bits.sof.

O d I ™ O |contador 4bits s e D ARG
CRES ;

Project Navigaturi A\ Hierarchy VJQ[_T;JE x ‘ $ contador_4bits.vhd on Report = contador. 4bits
= T B - =
EntityInstance P M7 EE N 0w % ——
N Cyclone V: SCGXFCTCTF23C8 -G ktop/proj dor_4bits - contador._dbits - [Chain2.cdf] =
contador_abits & File Edit View Processing Tools Window Help Searchalteraicom )

T e e B - I

[7] Enable real-time ISP to allow background programming when available

i File Device Checksum  Usercode  Program/  Verify Blank-  Examine
tart
Configure Check
o st0p
B8 Auto Detect
X Delete

™ AddFile...
pe e File.

I ] »

I® Add Device...
hyp

0
41 pown
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e Pressione Start para transmitir o projeto a placa FPGA.

» Programmer - C:/Users/Alunos/Desktop/projeto/contador_4bits - contador_4bits - [Chain2.cdf]* |5y
File Edit View Processing Tools Window Help Saarchaliariamm (%]
é Hardware Setup...| USB-Blaster [USB-0] Mode: |[JTAG x Progress: [ ]
[T Enable real-time ISP to allow background programming when available
File Device Checksum Usercode Program/  Verify Blank-  Examine
Configure Check
T e | - —
1 #listop ||| output files/contador_.. SCGXFCTCTF23  O0EC4318  O00EC431B 1 O O
‘ X Delete ‘
# Change Fi[e..,‘! A i ] :
— = = -
‘. @ Save File ‘
7® Add Device... i i £
’7‘%‘: 1 TDI L o
L weoe il :
[ Poown | “S—
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